Mumble push to talk problem

hi everyone,

I have a problem with push to talk in mumble that I don’t have in teamspeak (BF4 clan). when I use my push to talk butten (one of the side buttons of my mouse) the microfoon will open and close (don’t really now how to describe it in english). maybe this picture will discribe it better.

I’m using a corsair mouse and the corsair software to speaking in voip.

does annyone els have this problem in mumble and does anyone know how to fix this (maybe a other marco software that works with corsair mouses (I have the corsair M65).


Wesley (Boneface)

It sounds like your mouse software is pushing and letting go of the button immediately instead of holding the press until you release the button.

I’m not familiar with Corsair software, but maybe that helps you fix the problem?

Hi Jay,

this indeed same thing I thought, but this doesn’t fix my problem. the only fix that I know at this moment is using a normal key on my keyboard (this is not what I want).

Wesley (Boneface)

Is the “Suppress” box ticked for the button in your Mumble settings? It might be that something is overriding the Mumble program (as Jay mentioned). If suppress isn’t ticked, try it out and see if that solves it.

I will give it a look B1nary when I get home from school. I didn’t recall this checkbox, probably because I was installing mumble at that moment.

If you can’t find it, just let us know.

HI B1nary,

I can’t find the suppress check box. I have looked on this website: and I can only find 2 suppress option there. and I can make a shortcut with a suppress checkbox but I have to make a shortcut.

The shortcut is how you set up PTT in Mumble anyway.


If you just set the button you’re going to be using in there and check the suppress box, that should solve it, unless there’s a reason you haven’t done that already.

Hi B1nary,

I just joined a random server with one in it to test if this solved my problem, and it didn’t I still have the same problem.

its maybe the software that I’m using for my macro (corsair’s own software). what I have seen in the software the button will be pressed every 50ms, I have tried it to set to 0 or 1ms this had no effect.