Sound clipping issue with brand new Arctis 9X

Hey everyone, just wondering if anyone might know another type of fix for this issue. Yesterday worked fine after resolving connection issues. Today, cannot get it to stop clipping. I have disconnected and reconnected (both headset and bluetooth dongle, multiple times), ensured drivers are updated and I have restarted my PC so many times I’m gonna wear out my bios :slight_smile: Only thing I wasn’t able to do is reset the headset with a paperclip. Can’'t feel the “button” anywhere. I do have a ticket into the company as well. Thanks.

Dagger26

Have you tried to uninstall/reinstall the software?

I have. I’m an IT guy from the 90’s so I’m still able to do the basic troubleshooting. As I mentioned, out of all potential fixes I could find, only the physical headset reset wasn’t done. Even tried shutting of different frequencies on my router. Move all other devices more than 5 feet away…no change with clipping. After each new step, I would repeat all the other steps as well. When I suspended 2.4ghz for example, I went thru the entire remove, reinstall, reconnect processes…I am at a loss.

Edit: Quick update. I could not make this work…had to return them. Got a Razor Kraken instead, straight USB connection, works like a charm.

© 2013 - 2021 Atlas Defense Industries LLC