NIC issue (I think)

On my home network I have my PC wired to my router using cat5 ethernet cables.
Over the last couple of days I noticed my down speed has dropped from around 6MB/s to 1.2MB/s
After doing some troubleshooting I’ve managed to trace it back to the LAN connection as speed tests through wifi connections are giving me the correct results however tests through the LAN are giving me results of 9.54mbps.

I then ended up into my NIC settings and it seems my NIC is only running at 10mbps and I cant change this even by setting the speed and duplex to 1.0gbps full duplex
My router/modem (BT homehub5) and NIC (Realtek PCIe GBE Family Controller) are both gigabit.
I’ve tried reinstalling LAN drivers, no change.
I even found some people with the same issue solved by simply disconnecting power to the system which I tried to no avail.
You think this is a faulty NIC or is there possibly something else I may have missed?

I would power off all devices, Modem/Router, PC, etc for 30 seconds…maybe assign Static IP to computer.

I have tried both a restart and a full reset on the router/modem. I’ve also tested with another PC wired directly to the router, that worked fine so I’m pretty confident it isn’t an issue with the router/modem.
That being the case along with the fact multiple speedtests are all giving me down speed of around 9.5mbps and my NIC for some reason being locked at 10mbps I’m leaning towards it possibly being a hardware issue with my NIC. In ‘properties/configure/general’ for the device it says its working properly though which is frustrating.

I’m tempted to just buy a new NIC but I wanna make sure I’ve covered all bases first.

Have you tested the cable between the two? It’s really easy to get a damaged cable/cable ends and get a wire that will only do 10mbits.

Yea I’ve tried a few different cables all with no change. I’ve even tested them with another machine so I’m confident it isn’t an issue with the cables I’m using.

Problem solved. I’m using Ethernet powerline adapters/extenders. They seemed to be working fine but after resetting them the issue was resolved. Thanks for your time guys.

Yeah you failed to mention that important bit of information

I was thinking of those cause i have the same issue in my APT but you mentioned running from the computer to the router.

Yea that was me being a douche.