Mumble: Server connection failed

Gents and Ladies, I’m in a pickle.

Mumble has been working beautifully for me until this morning. I was logged on successfully last night (logged off around 00:45 CST), and by 11:00 CST, Mumble had decided I was not worthy… Or something like that.

Original issue: When attempting to connect to ADI (or any randomly selected public) server, I would receive the following error message:
Server presented a certificate which failed verification…
The specific errors with this certificate are:

  1. The host name did not match any of the valid hosts for this certificate
  2. The certificate is self-signed, and untrusted

Do you wish to accept this certificate anyway?
(It will also be stored so you won’t be asked this again.)

Selecting “yes” to the above would cause this error box to close, only to almost instantly pop back up again.

With assistance from Weard, I did the following to attempt to fix it:
-Ran mumble as admin
-Deleted any certificates I could find from Mumble
-Created new certificate
-Registry repair
-Restarted computer
-Created “trusted” certificate

Creating “trusted” certificate appeared to resolve the original issue. I no longer saw “certificate failed verification”, but then a new error occurred when I tried to connect to ADI or (again, any other randomly selected public server):
Server connection failed: The remote host closed the connection.

That error consistently occurs 1 second after the “connecting to server” log.

To try to get past that, we tried installing the unofficial Mumble 1.3.0, but the original error popped up there and no amount of certification maneuvers got us past that, so I reverted back to 1.2.8.

Additional steps we took to get past the “server connection” error:
-Unchecked Quality of Service
-Checked Force TCP mode

I’m running Mumble 1.2.8 on Windows 7 64bit. Mumble has been working wonderfully, as stated, until this morning. The only changes to my system in the past week was a Java update on 04.29.15 (two days ago) and becoming a recruiter last night (some permissions were switched around). However, I hesitate to think it has anything to do with my permissions within the ADI mumble, seeing as I can’t connect to any public servers either.

I’m stumped. I would appreciate any and all help here.


Try to uninstall it and then wipe %AppData%\Mumble.
After that reinstall.

Tried this. Searched for and wiped anything associated with Mumble, then emptied recycle bin and reinstalled. Did not resolve. Still receiving “Server connection failed”.

Wow that’s a problem coming from space oO. I’ll try to think about what could be the cause but right now I have nothing. You are experiencing the same on public servers? Have you tried launching it as an administrator? Have you tried using another pseudo?

Tried running as admin, have not tried using another psuedo. Do you mean changing my name, or trying another computer?

I meant changing your name.

Another thing that you could try is to disable your firewall. Also check if there aren’t fancy things happening on your router that could block something maybe (just trying to throw some ideas).

EDIT/PS: All I see by looking about your issue on internet is people solving it by removing the sqlite database in %AppData%\Mumble, but since you tried it unsuccessfully…

EDIT2: Try to use a VPN, maybe something is blocked at the ISP level on your IP.

Check your firewall rules and restart your router would be my next steps too.
If that doesn’t help use wireshark to monitor mumble’s communication.

Tried changing my name. DNR
Reset my router. DNR
Added Mumble as “program allowed through firewall”: DNR
Disabled firewall completely: DNR

Next? lol.

I’m not sure what that is or how to use it. Easy enough or worth being talked through?

It’s probably a bit hard if you don’t have networking knowledge to use Wireshark unguided. It’s a packet analyzer.

I’ve got it installed and running. I do not have the first clue how to set this up properly though. Would you or philux mind helping me get it started?

Been some times since I’ve used it, and never ran it on windows.

At the beginning you have to choose the network card from which packets will be captured. If it’s all grayed, try to run it as admin. Once the network card is chosen, you can click on “Start capture” (something like that). It will start recording and displaying packets.

It will show a lot of packets, you can use the little text box on the top left corner called “filter” to add a filter and show only some packets. I don’t really know what kind of packets you could filter to get only the mumble ones, maybe an IP filter on the IP address of the server.

With this you could potentially see what is happening (what kind of packets are going through, what are the “error packets”). You can click on a packet and in the bottom of the window you can see some details at different levels (network, transport, etc.).

Well, I’m giving it my best shot here but I think someone a lot smarter than myself is going to have to look at this thing. I don’t have a clue what I’m looking at here. I can see logs of what’s happening when it tries to connect but I don’t know what it means.

I’m not sure if I can help with that, you can always try to drop some screenshots or export your results here so I can have a look, but I doubt I could get anything out of it :smiley:.


I’m out for pocket for another 24-36 hours… then I’ll give you a hand fixing this.

Thank you, Jay. I’m gonna keep fiddling with it to see if I can get it up and running again. I’ll try not to break it any more.

EDIT: Looks like I’m up and running again. Can’t really explain why, as I pretty much just repeated some earlier troubleshooting steps, but I’ll take it. Here’s what I did. Went into Mumble properties > Compatibility > Just to run the program in compatibility mode for Win7. Also checked the box to always run as admin instead of right-clicking every time. Then I launched and created a new self-signed certificate. Got the original “certificate not validated” error when I tried to connect, clicked yes… and it worked. Viola.

I got that same error this morning. I fixed this problem by going to Appdata, then to Roaming, followed by mumble, and deleting mumble.sqlite from the folder. I was able to connect right after that.

Here is a crazy and wild stab in the dark… if you have a restore point have you tried to roll back to a previous point prior to this happening?