Mumble certificate error

I get the following message.
Server presented a certificate which faliled verification…
The specific errors whith the certificate are:

  1. The host name did not match any of the valid hosts for this certificate
  2. The certificate is self-signed, and untrusted

Do you wish to accept this certificate anyway?
(It will also be stored so you wont be asked this again.)
yes no view certificate

Its frustrating because I was just on mumble before my computer had to restart and now it gives me this message every time I try to log on. I haven’t changed anything when I log on to the server.

This is completely normal for a self-signed (read “free”) certificate like the one used on our Mumble (and 99% of Mumble servers out there). The client will always issue this warning the first time it thinks it is connecting to a new server. You have the option of permanently accepting it so it doesn’t become an annoyance.

I tried to accept it but it will keep giving me the same message for 20 clicks and then attempt to connect and it will always fail to connect to the server and mumble will tell me server connection failed: the remote host closed the connection.

Did you happen to create a new certificate?

I think I did the same thing is there a way to reset your certificate?

Same here. Computer restart, and then " Server connection failed: The remote host closed the connection."

I am having the same problem on multiple computers with different operating systems. So, not an operating system problem. These are fresh installs of mumble. Please do try a fresh install on a test system and see if you can replicate the issue. Any help would be appreciated.

All: Here is a solution. I have tested method 2 below and it works. Link to web page is: … red-Users/. Any chance that I can get help with method 3 from an admin?

Method 1: Import your old certificate

This is the best option if you still have a backup of your old certificate. To import your certificate click on Configure → Certificate Wizard. Select the option Import a certificate and then follow the wizard to find your old certificate.

Tip: When you install Mumble, an automatic backup of your certificate is saved to your Documents folder, under the name MumbleAutomaticCertificateBackup.p12. If you haven‘t created a new certificate since installing Mumble this should be your current certificate backup.

Method 2: Use a different Name

Connecting under a different user name (one that is not already registered on the server) will allow you to get back into the server right away. You will need to do this for every server that you were registered on.

Method 3: Delete the old registration

Ask one of the users on your server who have administrative access to delete your old registration. They can do this by clicking on Server → Registered Users, and then highlighting your name and clicking the Remove button. If you have the SuperUser password to the Mumble server you can log in as SuperUser and perform these steps yourself.

As with method two, you‘ll need to do this on every server you registered with.

I haven’t had a chance to try out any of the suggestions as I am away for an extended period of time and don’t have access to my certificate. I personally would try method #3 since I’m using a laptop and not my desktop and I’m not at home.

Connect with a 1 on the end of your callsign, and any team lead or director can fix it for you.

Just in case anyone needs this down the line, after the following didn’t work…:

  1. Import old cert.
  2. Delete old certs and create a new self-signed cert.
  3. Verified address.
  4. Ran mumble as admin.
  5. Checked mumble network settings.
  6. Added 1 to username.
  7. Checked firewalls.
  8. Downloaded 1.3.0 - verified we got the correct version for 64-bit machine.

… We finally arrived at a solution by changing the name of one of the sql files. Here’s the link to the post: … ease.1590/

Hopefully that helps someone!