Joystick "FUN"

I has to unplug all my controllers to get Valheim to work. Today I tried getting back into star citizen but apparently now my throttle and joystick are reversed as is I control straffing with joystick instead of throttle control, etc. Any command line suggestions on fixing?

Figure out which input number each is registering as. Swap them in console with this command:

pp_resortdevices joystick 1 2 (where “1” and “2” are your actual input devices)

Thanks, that got me closer though have a lot to sort out still. All my controls were reversed, though on the right device, throttle is still backwards and can’t shoot for some reason. But I’ll get it sorted out. Thanks again.


More advice I learned from @Frakk - possibly applicable:

Controls - HOTAS 2 - Inversion Settings - Flight - Flight Movement - (both) Throttle forward & Flight Strafe Forward = Yes.

Mind you, even since setting this myself, it may jump back to reverse inversion with a patch or some other snafu.
So maybe save the mapping notes on a Gdrive?

Godspeed. :crazy_face:

Yep. Very common that you need to invert in Controls menu these three by changing to “yes”:

Throttle forward
Strafe forward/back
Strafe up/down

Recommend going into AC free flight and doing it in there both to confirm and because it’s faster than spawning/pulling/running/flying in PU.

@Frakk ,
Ever seen that thing I mentioned where the inversions are confirmed set correctly to “YES” yet it reverts back to the original throttle behavior regardless?

Effing baffling.