Budget Performance Fix for Star Citizen

I was talking with some of the members in mumble who were having some issues with performance recently, and I went over some things that I do for 10-20 extra frames. After talking to the guys some tried it and they got more stability and some of them got double the frames.

Now I have a budget processor (only an i5) and an nvidia graphics card, but the fix works for AMD too and I’ll put the instructions for both below.

Star citizen is still an alpha and it has issues with optimization, so every frame counts

In Nvidia, go to Nvidia Control panel, then manage 3D settings, and Program settings. Select add and select Squadron 42 - Star Citizen (starcitizen.exe). The main three options we want to change are Power Management Mode, Texture Filtering - Quality, and Vertical Sync. Set power management to prefer maximum performance, texture filtering quality to high performance, and vertical sync off.

On AMD right click your graphics settings and go to Gaming, then click on Star citizen (or add starcitizen.exe), then set texture filtering quality to performance, and vertical refresh off.

5 Likes

I’ll have to test it more, but it looked like it improved drastically for me. Thanks for the info!

Made no difference at all for me :frowning:

If using a Gsync monitor you’ll want to leave Vsync on in the Nvidia control panel, and off in the in-game settings.

Does vsync on actually affect performance negatively, even if your setup cannot reach 60fps normally?

If I turn off V-sync in game I’ll get a frame update line that goes from the top to the bottom of the screen.

Screen tearing, huh? I get it in some games, which is why I run vsync in most. It generally prevents it.

One other way to avoid screen tearing is to get a g-sync monitor.

© 2013 - 2019 Atlas Defense Industries LLC