3000Mhz RAM only runs at 1800 - XMP Does not work, nor does BIOS overclocking

SOLVED

Hi everyone!

I got a new Motherboard (x570 Aorus Ultra) since I want to upgrade from my Ryzen 5 2600 ssoon. I kept the RAM (G.Skill Aegis 2x8 GB DDR4 3000) but I noticed that it only runs at 2133Mhz. I enabled XMP (or tried so) and the BIOS just didn’t apply the new settings to the RAM. Even in BIOS it still shows it running at 2133Mhz although all settings have been changed and are shown there as well. Before I noticed that, I ordered the same kit of RAM again, someone told me Star Citizen would run better with it, just installed it and the frequency dropped down to 1875Mhz. Why? Is my Processor too bad for that amount of RAM? I even punched the numbers in by hand and there still was no difference in Performance. What triggers me the most is that now, with even more RAM, It seems to have gotten worse and I feel like I have wasted my money. Does anyone have a solution to this? Also, on the side, my PC doesn’t shut down, when I start the shutdown it turns off for 1 second and boots up again in an instant. Correlation?

Edit: I cleared the CMOS and nothing changed.

I’m thankful for any help :slight_smile:

Icy

whats your MoBo?, it sounds like your mobo or CPU doesnt support XMP

Ryzen 5 2600
Gigabyte x570 Aorus Ultra

Its not the cpu, i had an old MSI board before this and XMP worked.
It has to be the new BIOS or the new MB


it looks like it doesnt support 3000 Mhz Ram.
check the memory support list, and make sure your ram is supported

SOLVED

I have solved the issue, still thanks for the help :slight_smile:

Out of curiosity, and because maybe others would be interested, how did you solve it ?

1 Like

© 2013 - 2019 Atlas Defense Industries LLC