x52 pro version help needed

i have the Saitek x52 pro

works fine with drivers installed, and works atm in SC

how ever if i try and use either logitech or madcats profile software every ting goes to hell./…

Any advice or ideas are welcome… cuz i would like to use it having the abilitry to switch profiles.

running i7, 16 gb, 960 asus strix card.

USB 2.0

Win 10 or 7? Also, you running latest version of software?


ive tried the beta software from Saitek, the std. package from saitek

the puff up logitech version.

(all 64 bit.)

Here is my setup, maybe it will point you in the right direction. Windows 10 Home 64-bit. I have an X52 (not pro) connected through an old 2.0 hub. For reasons I haven’t fully determined, it has power and calibration issues when connected directly to any of the USB ports on my system (including 2.0 ports) that go away when connected through the hub. Version of drivers didn’t seem to matter either. Currently I’m running the Saitek Drivers and Software version (64-bit). The profiler software doesn’t give me any issues. On rare occasion in SC I have an issue with x/y center drifting but it may be related to a bug with switching POV using F4. I haven’t fully tested it out to see yet. Other than that, my setup is pretty stable. At some point I’ll look into loading the new Logitech drivers to see what effect they may have.

FYI, just updated to the new Logitech profiler and drivers. No issues. It is possible it may be a hardware issue. If you have some USB hubs lying around, see how they affect issues.

A powered usb hub is often the solution for most of these issues.

im gonna look for a powerd USB hub since ive tried all the software. all ports ive been using is directly attached to the computer so no hubs or nothing.

thx for the replies.-

Power draw is often the issue, as the x52 series is on the high end of the usb power spec, and boards often don’t reach or maintain the right voltage and amperage needed, which can cause the x52 to continually reset, or just not run reliably (especially with all the lights on too).

Yeah, familiar with that issue. However, I think there are other factors at play as with my X52 (non-pro) it didn’t help to have the hub powered. With one USB 3.0 hub I tried issues with the controls flaking out got worse when powered versus not-powered. When connected directly to a motherboard port or addon card it was unusable, but if connected through the USB 2.0 hub I’m using now it is completely stable. Connecting the a/c adapter to the hub makes no difference. I think a lot of us just through various hardware combinations until it seems resolved and make assumptions as to the cause.