Windows not using all of the available RAM

So, I’ve looked around at this for a while, then gave up on it, but I figure it is time to look again.
All of my RAM modules work just fine individually, and I’ve tried all of the slot swaps to see if they work. This same thing happened with Win7 Pro (64bit) and Win 10 Pro (64bit). It should be supported according to my specs.

So, why in the world is windows only using 16GB? Any thoughts on this?
[attachment=0]Capture.PNG[/attachment]

OS: Win 10 Pro 64-bit
Processor: AMD Phenom II x6 1055T (http://www.amd.com/en-us/products/processors/desktop/phenom-ii)
Motherboard: AsusTek M5A97 (Rev 1.xx) (http://www.asus.com/us/supportonly/M5A97/HelpDesk_Download/)
RAM: 32GB (4 x 8GB) DDR3 1866 (http://www.gskill.com/en/product/f3-2133c10s-8gsr)
GFX: R9 380 Gaming 4GB (http://us.msi.com/product/graphics-card/R9-380-GAMING-4G.html)
Sound/Network: on-boad/integrated

Thanks in advance! I’m hoping new eyes on this can help.

support.microsoft.com/en-us/kb/978610

Thanks for the reply! I found that link last time I messed with this, but I tried all the options again, just in case, but no difference.

When I get some time, I’ll retest my RAM and see what happens. (last time they all tested fine, but, maybe something has changed)