Downloaded 2.6, no problems. Started updating…

Blue line full. Little blinking curser next to the word UPDATING…for the last 3 hours.

Something I’m missing or is a 3+ hour update (not download) normal?

Can’t say I’ve ever seen nor heard of that before.
Tried restarting the launcher in it’s entirety, closing all task-manager instances (if any), then clicking verify files?

Yes. Most recent attempt was to uninstall the launcher then download again. Same results.

No problem downloading and the updating bar moves to completion. Then just continues to say “updating” with a blinking cursor for hours (6+).

EDIT: Is there another file besides the installer CIG puts on the computer? Maybe I’m not uninstalling all of the program.

gyazo.com/98dbad0427ac651913148dac3574bd65 Try this

Sinlo. Linky no worky. But the guidance you gave me did. 2.6 download installed immediately after I took the actions you gave.

The link worked for me. For anyone else having this problem or the updater is dominating your bandwidth, they recommend the use of a VPN like Tunnelbear for your updates. Turn on Tunnelbear for your update and turn it off when it is completed.