Trying to get back... Help!

Hello Everyone,
As some of you are aware, i’m having some issues with my HOTAS - it’s infuriating.
I have a X56 Hotas. It worked perfectly until just before Xmas when I lost the ability to use the Joystick. I’ve tested, tweaked and thumbled about a lot and I’ve identified the issue…

The Throttle and Joystick both work fine, physically and in every other programme other than SC.
However, Windows for some inexplicable reason (might have been a windows update, or my son plugging in an xbox 360 contorller that he’s not previously used on the PC) has decided to Identify my Throttle as device number 4 and the Joystick as device nukmber 5 rather than 1 and 2.

Here’s my issue with the above… I use an profile off of spectrum that a guy has created using SCJMapper that’s avalible on GitHub - I dump his XML file in to the controls folder then tweak using the GUI - I’m happy doing this and the controls are ideal. I go back to his spectrum page and pull the updated XML when the game has an update, he kindly updates regularly.

So… in this XML file the devices have been identified as Throttle 1 and Joystick 2 - this is understandibly not compatible with how windows has decided to identify my HOTAS :frowning:

I’ve tried unconnecting all devices, uninstalling every user interface device and then restarting PC and plugging things back in but for some reason the PC REMEMBERS and reverts to the messed up ID list. I’ve looked on the internet and there’s a lot of people that have the same issue - it’s Windows 10 and there’s no way to delete identified deviced from your list or to change the I.D numbers manually. There used to be a third pary programme but it’s not been updated for a while and it’s no longer compatible.

I’ve even tried to edit the XML file manually and line by line, using notepad to change the device ID association but it’s not worked - I may however be doign this wrong. Could anyone look at the XML file for me and walk me through what needs changed?
I’ve even tried manually choosing the device for the controls using the GUI, going to options, advanced setting and yaddayaddayadda… no luck.

My only options are to:

  1. Setup the HOTAS and Joystick manually. I want to avoid this becasue I can’t use the GUI becasue of it’s inability to set ‘double tap’ and limitatiosn on how to use x/y axis. i would therefore have to teach myself SCJMapper and create the file in there. I’m not apposed to this but it’ll be an ache and it’s more time than I have atm.
  2. Unplug my devices from the PC, launch SC then plug in each device in turn so that Windows accepts the new devices as they’re plugged in and assigns me desitred ID numbers - i would have to do this everyime I launch the game.
  3. Accept a solution from one of you! I’ve my fingers crossed :slight_smile:
  4. play with Mouse and Keyboard until I get enough time to learn SCJMapper and then reconfigure everything. This is my prefered method but i really don’t have time.
  5. Appeal to Microsoft and get tehm to sort Windows 10, give us the option to edit and assign device IDs.
  6. Appeal to SC to update the UI so that we can create our controls better.

Please help!

I’ve been absent from Mumble for a few weeks because of this but have been keeping up todate with Discord and the Froums here.

Try these, see if they help.

1 Like

Thanks Grim,
These both suggest that it’s an issue with SC and not Windows. It makes sense as there’s a post that I read on spectrum from a guy having the same issue. He ranted that CIG should update their outdated system to accept device IDs - I didn’t understand what he meant but this puts it in to context.
I’ll try unplugging everything then plugging everything back in, in order, once the game has loaded. I suspect that this will allow SC to identify my devices in the right order :crossed_fingers:
I might get a chance tomorrow.
Thanks for the reply!

I thought you had already tried that solution…

If you read through one of those links, it says you have to go through all controllers and set each one as “Primary” before removing it so the Windows will “reset” it.

1 Like

No,. It once the game has loaded. I’ll was hoping to get a look today but.itll be the weekend. Thanks for helping.

1 Like

© 2013 - 2019 Atlas Defense Industries LLC