Trouble with Logitech TQ

I wanted to share my experience with a simple Logitech device I recently received in hopes it helps someone in the future.

Logitech Throttle Quadrant

The device after being plugged in caused my game to lock up shortly after launching and wouldn’t go past the orange sunset it shows you when launching. The came would enter a state of “Not Responding” and then close.

Tried the usual driver update, restart, reboot. These did not solve the issue and I still couldn’t get to main screen.

  • deleted the user folder

This finally cleared up the issue and the game worked fine for about 4-5 hours. AND… in the middle of an Idris fight, I crashed to desktop and immediately tried to relaunch only to get stuck in the endless “Not Responding” state.

  • Dumped User folder & Rebooted.

After booting up the power light was off. I noticed it would flick on for a moment when plugging it in before staying off. It only blinked once. So I did the usual and tried several other ports.

  • I remember hearing in mumble that Logitech likes power USB hubs. So I don’t have one but I do have a powered USB switcher (switches devices between inputs) (has the light on it in the image)

This USB hub didn’t have the 5v power cord plugged into it so I plugged it in and moved all my Star Citizen controls to this hub (I didn’t need the switcher anymore my Pi 4 was set up already).

!! YaY. !! The power light came on. I rebooted the PC and rebound all my controls. (device order got switched around again!)

  • I hope this information will help someone in the future.

© 2013 - 2019 Atlas Defense Industries LLC