Keybinds - Keyboard - Help

#1

Is there a trick to getting Keyboard Customization buttons to work in game? Trying to bind “Open all doors/Close all doors”

No matter what bind I choose and set in customization, it doesn’t work in game. I save the profile, reload game, change profiles, etc. The bound key just will not work.

0 Likes

#2

Possible it’s a big worth reporting. Check with other ships as well.

1 Like

#3

yeah been trying with Valk and 300i. In PTU. Trying to hot key my doors for drop ship.

0 Likes

#4

Did you try hitting the keyboard button twice in rapid succession, like a double tap? I have two of my mouse buttons keybound to ‘reload’ and ‘next weapon’. I almost always have to double click the button to get the keybinding to work.

Next time I’m in game I try to bind a key to the doors and see if it fails for me.

M

0 Likes

#5

Yeah, tried a lot so for. Just straight up feels like the game is not acknowledging setting or perhaps it is a per ship thing and just haven’t found a ship that’ll react to it. I’ll have to try other ships, maybe one that has been around longer. Because I do recall the Valk since it was introduced never responded to the old door key pre 3.5.

0 Likes

#6

example would be freelancers landing gear not working when using a HOTAS and in orbital views. It acts strange and does not operate properly. So buggy yes, maybe.

0 Likes

#7

Those keybinds actually do not function at this time.

EDIT:

Here is the issue council

1 Like

#8

Only did the following in 3.5 PTU so far, but looks like the open/close binding work.

I went to Aeroview Hangar and spawned a 300i. In bindings I bound both open and close to the same key (in this case semicolon) with Open to double tap, so you only do it deliberately. I hit F4 for external view and sure enough it worked. I’m going to load into PTU to test it some more.

1 Like

#9

It would be awesome if they had fixed it. I didn’t even try. Please tell us if it works in the ptu!

0 Likes

#10

It would appear it only works in hangars. With the same ship and other ships in Stanton System, the mapping is ignored. I seem to recall this was the case before 3.5.

0 Likes

#11

As I have heard it and experienced, I don’t think it has ever worked in the public universe.

0 Likes

#12

Pre 3.5, I used to use advanced keyboard profile, and I think it is 9 that closed and opened. Never worked on valk but worked on other ships, i.e. 600i, HH, so on. So that’s why for me hard to tell if it is over all system issue or ship specific

Combining my info and the findings in this thread, who knows… everyone take a drink Haha.

Was hoping valk would have the button working so i could practice getting my dropship on : )

0 Likes

#13

Just read that issue council post. Created in 2017 : ( Apparently only a handful of folks want this feature working haha. Oh well, one day.

0 Likes

#14

I -believe- some other bindings do not work, I tried importing my mappings from 3.4 over to 3.5 PTU to automatically map some keys, and some worked while some didnt, despite showing up as successfully mapped in the keybinds, waiting to see if the live version will have similar wierd things happening.

0 Likes

#15

Yeah, there are MAJOR changes to default mappings with 3.5.0, in addition to some functions being removed and others added.

I HIGHLY recommend building a fresh profile. Importing from 3.4 or earlier will not go well.

0 Likes

#16

I wasn’t talking about the default ones though, I was using a mappings file and after loading the file in the PTU profile, for example “K = lock all doors” showed up correctly in the keybinding, except pressing K ingame would do nothing at all, while another custom map would work.

If we are talking about the same thing ignore this post :joy:

0 Likes

#17

Oh, I understand.

One thing people should know when they are exporting their keybinds is that the resulting .xml file contains only the changes from the default bindings at that time. If something isn’t changed, it isn’t in the XML at all.

With the significant changes to defaults going from 3.4 to 3.5, you can end up with many conflicts and unexpected results.

0 Likes

#18

Now I could be wrong, but from memory the custom keybinds through the mapping profile that work were those related to options that are STILL on the default keybind image shown ingame, all those that were removed doesnt seem to have work despite being correctly bound. I’m waiting for live release to see if this will be a thing moving foward

0 Likes