File Browser's X55.xml Z-axis (YAW) not working

EDIT: as of 13. feb 2015 the XML file in the file browser is a wrong one for x55. Download the latest from ADI teamspeak tech support and place in under the \StarCitizen\CitizenClient\USER\Controls\Mappings . When in game and importing the file, leave KB blank and put joystick 0 to the uppermost joystick and joystick 1 to the 2nd joystick slot. enjoy. I hope we get the correct file in the forum’s file browser soon.

File Browser’s X55.xml 1.0 Z-axis (YAW) not working. Everything else works just fine but not the Z-axis. I hope the problem is in the xml (and not on my joystic). I need some help fixing it and fix the xml for everybody aswell (if that’s the problem). Thanks!

You may want to manually rebind just that movement, then see if it is working. I use the x55 and the xml, but did not have that problem.

just be sure you only do the manual keybinding for just that movement.

let us know if that did the trick or not.,

I’ll try that. If I’m the only one that has the problem, then the xml should be just fine. Posting results later

Ok the problem isnt with the yaw. Its with me not getting the xml to work. Not at all. I don’t understand what I am doing wrong since I’m following each step as advised and it’s not supposed to be a difficult task. Still everything is broken.

Siitosori,

I just checked the pfd instructions in the file browser folder and there is an error of where to place the xml file.

the actual path to place the xml file into is

StarCitizen\CitizenClient\USER\Controls\Mappings

The rest of the instructions should be good.

Do not delete your user file after you put the xml file into it.

Since you have had some issues, I would delete your user file, start SC so that it will recreate the user folder, then exit SC and place the xml file as indicated above.

If you are still having problems let us know.

Hope this helps

EDIT: Ok it is labelled as X-55 in the options, but main problem is now that I have there on the list 1 keyboard and 3 joysticks and I don’t know which one should be joy 0 or joy 1.

I realized this error, but I cant get the xml to show in in-game options anyway. It just is not on the list of the xmls i can choose from. That, plus that I have a keyboard slot and 3 different joystick slots showing when i should import and I dont know which ones should be priority 0 or 1. I dont understand at all.

Another issue might be that it’s designed to be used with rudder pedals and not twist.

As for the order, you should unplug all the other joysticks you have and game controllers so only your keyboard/mouse, stick and throttle are plugged in. Then Joystick 0 should be the Stick and Joystick 1 should be the Throttle. If you have pedals they’d be 2. Once that’s mapped, then plug in game controllers and other peripherals.

I have kb, headset, track ir, joystick and throttle in usb ports.

EDIT: I disconnected my track ir and kb so I only had stick, throttel and kb left. I still had 1kb and 3joystick to choose from. Tried all combinations and still not working. Buttons fucked up and no Z axis

Siitosori,

Please take a look at the dates of your xml file, If i am not mistaking is should have a creation date of 7 feb time of 356 and last modified date of 7 feb time of 1017.

I will keep a look out for when you are on mumble and we can talk through it if needed.

[url]http://prntscr.com/64oquq[/url]

  1. february. There is no newer on the website file browser

The website file browser has been updated to include the fixed version of the X55 and new instructions.

If you have any more issues just let me know.